Buddy Exchange down for some user

Incident Report for Vadacom Limited

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 13:00 NZST

Investigating

We have identified an Issue that may affect access to Buddy Exchange for some users.
Posted Jul 20, 2026 - 09:18 NZST
This incident affected: Vadaxchange Buddy (Vadaxchange Buddy - Admin Portal).